VS 2012 compatible?

Aug 21, 2012 at 5:54 PM

Is this already compatible for VS 2012 RTW?

If so, It doesn't work for me...

I don't get status icons and I don't get pending changes in the pending changes window.

I Have installed msysgit / git extensions and tortoisegit.

I checked options if they have correct paths and the source control provider is set.


Any idea?

Aug 22, 2012 at 10:50 AM

I had similar issue and spent quite a few hours tracking down my issue which had similar symptoms.

my git config file had the unicode BOM marker as the very first character, and it causes ngit (the library that GitSCC uses to not read the files properly).

These are the files to check

  • config (in your working folder, under the .git folder, the file named "config)
  • .gitconfig in your home directory.  (C:\Users\<your username>\.gitconfig)

Open the files above with Notepad++, in the Encoding menu, select UTF-8 without BOM or ANSI.

For me, I'm not sure how my files got changed, I think it was updating Git to version 1.7.11 or GitExtension 2.40.  I think those versions enforces UTF-8 and it is writing a UTF-8 BOM marker to the files thus causing the NGIT library to fail.

It may or may not help you, just what fixed it for me.

Aug 22, 2012 at 7:00 PM

Nice catch!! that's it (the config file in my .git dir was UTF-8 with BOM marker)

This should be added to the docs / addon description I think. Because this has me kept from using this addon since I first tried it in VS2010.


Thanks a lot!

Aug 24, 2012 at 3:40 PM

Thanks et381!

V 0.9.6 Beta 1 has the fix for utf-8 config file.

Aug 24, 2012 at 4:00 PM
Edited Aug 24, 2012 at 4:01 PM

Can also confirm this doesn't work on 0.9.5.

will VS Gallery be updated, soon?

EDIT: ha lol. just noticed you (YYSun) just replied, 20 mins ago :P oops.