Status icons not changing

Aug 22, 2010 at 5:51 PM


When I change a file under Git source control I don't see the icon change from the padlock to the red check.  However if I close and reopen the solution the icon is changed to a red check.  Also if I undo the changes of the file the icon doesn't revert back to a padlock, even after closing and reopening the solution, the files are the same but the icon is still a red check.

Is this only my computer that has this problem or is expected?


Aug 23, 2010 at 7:24 PM

The icon reflects the if the saved file and file in repo are different.  If modified a file, but not saved yet, the icon won't change. To your second question, you can try the "compare ..." menu to see what's different. The whitespaces will cause the files to be different.


Aug 23, 2010 at 8:14 PM

Yes, that is exactly what I'm doing. I open a solution, open a code file that has a padlock, edit the file, save the file, and close the code file, but the icon doesn't change to a red check in the Solution Explorer. 

I can also use the Git (master) > Compare... and it opens my file diff program and shows the changed file as expected.  But still no red check icon, even when I use the Git (master) > Refresh button. The only time I see red check is if I close and reopen the solution.

Also, I've tried this extension on two different computers and get the same results, one is WinXP VS2010 while the other is Win7 VS2010.


Aug 24, 2010 at 12:45 PM
Edited Aug 24, 2010 at 3:59 PM
It could be a bug. Questions: how many projects you have in the solution? What type are they? (c# web app, c# class library etc). Where is the .git folder located? Thanks, Yysun
Aug 24, 2010 at 2:22 PM

The project contains multiple class libraries, an MVC2 web app, a console app, a build project (just a class library with MsBuild targets and tasks) and a class library containing unit tests.  The .git folder is in the root of the solution, the same location as the .sln file.

I just tried it with a simple solution containing only a MVC web app and it works fine.  I think the problem is that I've organized the project files to exist within solution folders.  That is;


So I did a little experimenting and found:

  • Having multiple class libraries, console apps, and other projects in a solution works OK.
  • Adding a solution folder and then adding various files to that solution folder (text, html, diagrams or other documents) works OK.
  • Adding a solution folder and then adding a project to that solution folder fails to update the icons of files in that project.

Also, it doesn't matter if the project files are actually in folders in the file system that matches the above layout, what matters is that the projects are in solution folders in the solution explorer.

Let me know if you have any other questions.

Aug 24, 2010 at 4:04 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Aug 24, 2010 at 4:06 PM
Thank you very much for the detailed information. I have created a work item in the issue tracker and will start to investigate the issue with solution folders. Yysun
Oct 13, 2010 at 2:00 PM

I have installed version 1.0.0 in VS2010, and I do not see any status icon changes.  I do see the context menu, though.

I am working on a branch rather than master, could that be the reason?

Nov 4, 2010 at 3:45 PM

I now installed version 0.6.0 on a new VS2010 on a new computer, and a different branch (that is branched from the branch where I see the issue).  And there it worked.  Unchanged files show up with a padlock symbol and modified files show up as modified.

I noticed that the VS2010 where I saw the issue had version 0.5.8 (I think) and not 1.0.0 (at least).

So I uninstalled the 0.5.8 version in extension manager, and downloaded the and installed the 0.6.0 from the extension manager's online gallery, and restarted VS.  The files with changes still showed up without any icons.  Then I noticed that another (company internal) source control provider was active and switched to the git source control provider.  But that didn't help.  I tried refresh on the solution, and refresh on a file with changes but there were no icons displayed.

I tried another restart of VS2010, but there were still no icons showing up.  No modified icons, and no padlock symbols on the unchanged files.

Is there some leftover setting from the 0.5.8 install, that could be the cause of my problem?

Nov 4, 2010 at 4:58 PM

It is installed under: %LocalAppData%\Microsoft\VisualStudio\10.0\Extensions\\Git Source Control Provider\<Version>. Did you see 0.5.8 there?

Do you also have 0.5.8 for VS2008 installed? If yes, you can remove it from control panel.