Can't see Git Source Control Provider in the Visual Studio Gallery in VS2012

Sep 1, 2012 at 5:51 PM

I hope I followed the instructions, Tools/Extension Manager/Online then search. I can find other source control solutions, but a search for "Git" returns nothing.

Then  I tried to download the VS2010/2012 installer, and got a VSIX, but don't know what to do with it after that (it's not associated with anything, and Visual Studio doesn't want to open it).

I also tried manually copying the vsix to the Extensions directory in Appdata, but that doesn't work either (have removed it again now).

Any ideas?



Sep 2, 2012 at 4:39 PM

I'm having thesame issue.

Chen Wei

Sep 3, 2012 at 12:10 AM
Which visual studio edition are you using? Express, professional, premium or ultimate.
This extension does not work with express edition.
Sep 3, 2012 at 12:17 AM

I was using Professional.

Sep 4, 2012 at 7:59 PM

Please try to double click the GitSccProvider.vsix. It will be installed by visual studio.