Not getting status displayed in Visual Studio

Oct 17, 2010 at 9:53 PM

Hi,

I maybe I'm doing something stupid. I have a solution added to Git but I can't get the status in Visual Studio. I have...

- Installed Git

- Installed Git Extensions

- Installed Git Source Control Provider

- Added my files to Git and GitHub (using Git Bash)

If I open the solution (in VS2010) I do not see any status icons. I do have the menus (including the context menu items in Solution Explorer).

The only thing I can think of is maybe my file structure might be an issue, example:

--Acme.PetShop (folder)

----.git

----Trunk (folder)

------Source (folder)

--------Acme.PetShop.sln (solution file)

--------Notes.txt (file, added to the Solution under "Solution Items" Solution Folder)

----.gitignore (file)

----ReadMe.txt (file, not associated with the Visual Studio solution)

 

The only thing I can think of is that the Git Repository root is not the same directory as the Solution file. Is this a problem? Or is there something else?

Thanks,

Callum

Coordinator
Oct 18, 2010 at 3:46 AM

Hi Callum,

.git sitting outside solution root directory is supported. Have you selected "Git Source Control Provider" from Tools | Options | Source Control | Plug-in Selection?

yysun

Oct 18, 2010 at 9:46 AM
Hi,

Yes, I have definitely selected the source control provider.

Thanks,

Callum



On 18 Oct 2010, at 03:46, "yysun" <notifications@codeplex.com> wrote:

From: yysun

Hi Callum,

.git sitting outside solution root directory is supported. Have you selected "Git Source Control Provider" from Tools | Options | Source Control | Plug-in Selection?

yysun

Coordinator
Oct 18, 2010 at 1:51 PM

Hi Callum,

Do you mind if I ask you to zip the folder and email me so that I can try to reproduce the issue here?

Regards,

yysun

Coordinator
Oct 18, 2010 at 10:21 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.